
  

This tutorial is to show you how to use your computer to convert your legally 
purchased media such as Vinyl Records,  Audio Cassettes and CD's to mp3 
files to transfer to your IPod or mp3 player.

Be aware that when you purchase music in the above form it is copyrighted 
and is for your enjoyment only. You are not allowed to make copies to give to 
other people or illegally download other music files from the Internet.

The mp3 format for music files is also subject to copyright and patent and 
you should satisfy yourself that it is legal for you  to use in your Country, 
before you use "LAME" software to encode music files to mp3 format. If you 
are concerned here, the free Ogg-Vorbis format is widely available in our 
Linux distributions and the ogg files are now accepted by many mp3 players.

When you purchased the media such as Records, Cassettes or CD's, the 
price included a royalty that was paid to the artist and this allows the original 
purchaser to listen to the music.

The author of this tutorial does not condone the illegal copying of music files 
and you should only use media that you have purchased.

                                                                          26 April 2008   Leo Kavanagh



  

Convert your Audio Cassettes or Vinyl Records to a good quality 
audio file,  or mp3 format for transfer to an IPod or MP3 player

Leo Kavanagh   26 April 2008   
Use the free program  "Audacity"  to record the audio output from your cassette player, 
turntable, reel to reel,  or even CD's onto your computer's hard disk. Audacity is available at:

http://audacity.sourceforge.net/

The latest stable version is 1.2.6 and this is the one to download. A newer version can also be 
used,  but this is a Beta testing version and  may contain bugs.  On the above web page, you 
will find links to download the correct file for Linux, Windows or Apple Mac OS X.  The 
Windows version installs on XP or Vista. Linux Mandriva version is available on the DVD.

A link to an excellent Forum, which has a specific page for each OS (operating system) is also 
on the above page and an answer to a your problem may be found there.

An FAQ (frequently asked questions) page is also available and many helpful tips are listed.  
You can post a question on the Forum but you must register first.  This is standard proceedure 
for any Forum to stop unwanted or offensive posts and is simply a matter of filling in a short 
form with your name, password, email address and acceptance of basic rules.

I am using the latest test version 1.3.4-beta so my screenshots may be slightly different to the 
stable version 1.2.6.  The program is very similar on the three different OS's and I have used it 
on Linux Mandriva, Windows XP and Vista.  The screenshots on the web pages for the Apple 
Mac version look similar to my installation, so what I say here should apply to all OS's except 
for the location of some tool Icons and links in the drop down dialogue boxes.

http://audacity.sourceforge.net/


  

This is Audacity in Linux Mandriva (your view may be slightly different) showing the waveform 
of an MP3 track of duration 2 minutes 20 seconds. Notice the abrupt ending with no fade out, 
I don't like the audience clapping at the end of a song, very easy to remove with Audacity.

      Play    Stop               Record              Audio out level          Microphone in level  



  

When you first save a project, Audacity will save it in it's own file format  "fileName.aup"
This format is best if you are going to do a lot of editing over a period of time and may open 
and save the file a number of times. All the original quality will be saved as the file won't be 
compressed. This is similar to a graphic file where saving to a .jpg will each time result in a 
slight loss of picture quality.

Be aware that an  .aup  file can be very large and I found that recording the tracks from an 
audio cassette for 45 minutes created a 980Mb file. Because of this I edit and export my 
project as MP3 files as I finish each audio cassette. If you want the best quality, export your 
work as  .wav  files and these will be smaller than the original  .aup

You should initially save your work as an  .aup file as it only exists in memory or swap file until 
it is saved and a power failure or computer lockup will result in all the data being lost.



  

When you start recording your first project you will see that only the top or left track is visible in 
Audacity's Window.  The default installation sets the Recording Channels to Mono (why?) but  
you can change this in Edit ->Preferences -> New Window shown below. Click where shown 
and the drop down menu will have a stereo option.

The most common question asked on the Forum is: How can I record in stereo?

  Click here, select  Stereo

This Window allows a very large number of settings to be customised and a look through the 
selection panel on the left shows how you can change the default to your requirements. A lot 
of professionals use this program, maybe the cost is a factor here.



  

Connecting the Cassette player or Turntable to the computer is the first step and this will 
depend largely on the equipment you have. I have an old, good quality tape deck and I 
connect the "Line out" connectors on the back panel to the "Line in" stereo socket on the 
soundcard in my Desktop PC. This will give as good a quality as is possible from an audio 
cassette and is the ideal setup. Turn off all equipment before making connections.

For this live presentation on my Notebook computer I must connect the headphone socket on 
a  Walkman mini cassette player to the microphone socket on my Notebook as it only has a 
socket for microphone and speaker.  The newer Notebooks or Laptops may have a "Line in" 
socket which would allow you to obtain better quality. My old tape deck has no way of 
controlling the output level of the "Line out" sockets and this overloads the Microphone socket 
on my Notebook. Use the "Line out" socket on which ever media player you are using.

Because microphones and turntables both have a low output voltage they normally require a 
pre-amplifier to connect to a "Line in" socket.  In my case here, I can turn down the volume on 
my Walkman until I see the recording level is not too loud when using the 
Microphone socket on my Notebook. This is not an ideal setup and doesn't
result in good quality sound. Click File ->New to open a new project.

Audacity does allow some adjustement of the input level but can't allow
for a "Line out" socket to be connected to a  "Microphone"  input socket.

Use this slider to fine tune the recording level so that the top and bottom
of the waveforms are not "clipped" as this would result in distortion.

Click the "record" button in Audacity,  this will be a test run only.
Start the cassette player and watch the peaks of the waveforms, they 
should all stop before reaching 1.0 on the level scale. An occassional
high peak is ok, but if it happens regularly then you will get distortion.
When you are satisfied with the recording level of the loudest sections,



  

stop the cassette and rewind, click the Stop button in Audacity. Click in the main window and 
then Tracks ->Remove Tracks. When ready to record, start Audacity first by clicking the record 
button. Now start the cassette player and don't worry if the  first section of the recording is 
blank, this is easily edited out. Providing you have enough free hard disk space, it is easiest to 
let the cassette run to the end and then edit it later. Extract the tracks individually if you feel 
confident of making the correct settings. Project example below.

Four music tracks, note the first is clipped resulting in some distortion. Total time 13:30   



  

I compiled the previous project from four MP3 files only as an example, to show editing.
The size of the '4tracks.aup' project is 284Mb and that's for only 13 min 30 secs.

Tracks ->"Remove tracks" will clear all recording from the Window.  You may have to click in 
the main Window to enable "Remove tracks".  To remove one unwanted track, highlight it and 
Click Edit ->Delete, or Cut to send it to the clipboard. Audacity can open multiple windows for 
cut and paste. Click File ->Open.

Zoom In:   A more accurate view of a section of track centered on the cursor
Zoom out:   See more track in the Window
Fit Selection:   Fit a selected section of track in the Window
Fit Project:   See in the Window the total project that you have recorded

Zoom in     Zoom out    Fit Selection     Fit Project

When saving project as an .aup file, Audacity will 
open a new Folder and a file in current directory.

Pause          Skip to Start      Skip to End

See the next slides for tips on editing



  

To edit our first track:     Select the first track + a little extra at each end. Click "Fit Selection" 
and it will all fit in the Window as shown below. Duration of first track 2:25.

The track was recorded at too high a volume and the only fix is to re-record it.  I have now 
highlighted (selected) the complete track 1, including 2 seconds  at the start and finish. 
Click File ->Export Selection and in the Window that opens, select MP3, enter a file name 
such as   "MySong"  and when you have navigated to the correct Folder, click Save. The file 
extension will be added by Audacity and the full file name will be  MySong.mp3.

If Audacity complains about a missing library file, see the next page for how to download the 
file for all 3 OS's.  MP3 is a patented file type and it is illegal in some countries to use it or to 
encode to it without paying a royalty.

To start Play at a certain point, click once in the time panel, that is where the seconds are 
displayed. This is handy when you are editing and you need to replay many times. The small 
triangle in this panel marks the Play start point.



  

Linux only:   The version supplied by Mandriva 3.97-2 doesn't work for me. The required 
library file  - "libmp3lame.so"   is not present on my system. Check first to see if Audacity will 
encode the selection for you before taking the following step.
  Download LAME as source code from it's home page and compile it as a shared object, 
then check that the file  "libmp3lame.so" is in  /usr/local/lib.

Home page: http://lame.sourceforge.net/index.php

Final download page:  
http://sourceforge.net/project/showfiles.php?group_id=290&package_id=309

Select file:  lame-3.98b8.tar.gz (This is latest Beta release, it works fine on my DesktopPC)

This source file compiled with no errors and installed the missing library file in  /usr/local/lib

A  few  tips
When I have successfully exported a track as mp3, I select Edit ->Delete and the track I have 
saved is removed from the project. File ->Save to save the rest of the project.

If there is very little space between tracks, you can introduce some by highlighting the time 
duration of silence at the point you want it inserted. Click Generate ->Silence ->ok.

Error message on Linux when first trying to save the 
Audacity project as an mp3 file.  A similar message 
will also appear in Windows. Not sure but I think the 
same applies to Apple Mac computers.

Easy to fix; download and install the correct file for 
your system and you can then encode mp3 files.

Windows and Mac use this page: http://audacity.sourceforge.net/download/lame

http://lame.sourceforge.net/index.php
http://sourceforge.net/project/showfiles.php?group_id=290&package_id=309
http://audacity.sourceforge.net/download/lame


  

Tips continued

Check the many options under "Generate" and test them.  Audacity gives us Edit ->Undo 
which is very handy if we make a mistake or simply change our mind. 

Remember we are editing a project in memory and if things go wrong, simply close the file 
and when asked  "Save changes"?  answer No. The original project is still saved on the hard 
disk and you can reopen it and continue from the last satisfactory saved point.

Listening to the music as you record, is not selected by default: Click Edit ->Preferences -> 
Audio I/O Select:(Software Playthrough)  Play new track while recording it.

Edit ->Trim will trim any sound outside each end of the selected area. Be careful if editing a 
complete project.

Vertical black line (like a bookmark) click to remove.

If a track finishes abruptly, you can add say 1.5 seconds of silence so that the next track won't 
start immediately the current track finishes.

If you started recording in Audacity say 10 seconds before the sound started, this is too much 
silence, to make the silence around 1.5 seconds, highlight from zero to 8.5 seconds then 
Edit-> Delete will remove the excess silence.

Click  "Skip to start" before recording to ensure the cursor is at zero.

When I installed LAME on my Notebook a week later, a new Mandriva package was available 
for 2008.1 Spring, and this installed and worked ok. This is an ftp link to the file if you are 
having problems. This server is the default in my Software sources. It is not a link, copy and 
paste (to avoid typos) into the Address field of your Browser to download. Don't use for any 
other Mandriva version of other Linux distribution. 

ftp://mdk.linux.org.tw/pub/plf/mandriva/2008.1/free/release/binary/i586/lame-3.97-3plf2008.1.i586.rpm



  

Tips continued

This Mandriva rpm is much easier to install than the source code and is a stable version. The 
package mentioned from the LAME web site is a Beta testing version.

If using Windows, the program to control your sound card will give you many options for 
controlling the settings.

In Linux Mandriva, Kmix settings for "Line In" and "Capture" must be selected.

To get the best quality audio files possible, clean your vinyl records, clean and demagnetise 
the recording and playback heads on your tape deck or reel to reel recorder.

In Audacity Window, click Edit ->Preferences ->Audio files ->Find Library and Audacity will 
search your system to see if you have LAME. If not, click "Download Free copy of LAME" and 
your Browser will open at the download page.

In Preferences ->Directories you can set the time interval to write the current project from 
memory to a temporary file on the hard disk. Saves losing data if a problem occurs.

To close Audacity after you have opened a project, click File ->Close then File->Exit. For me, 
clicking on the X at top right of Window won't work. Maybe this is Audacity's way of stopping 
you exiting without saving your work.

END
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